Network

Mikrotik Bgp Ayarları

Mikrotikler arasında yada Farklı Bir Router ile konuşması için, Bu ayarlar ASN ve E-BGP dahil olmak üzere BGP ile ilgili temel konfigürasyonu tanıtmaktadır. TCP bağlantısında BGP kullanımı, internete bağlanırken, Sınırlı Ağ Geçidi Yönlendirme protokolü (BGP) olarak statik yol veya bir yönlendirme protokolü adı kullanabilir.

NOT: AS Number Ripe Gibi İp hizmetini aldığınız ip üretici ve dağıtıcı firmalardan size verilen bir Kullanıcı Adı olmaktadır.

ÖRNEK : AS42926

Örnek olarrk bir As Number takibi yaparsak nasıl bir gablantı yaptıgını ve buna baglı network yapısını görebiliriz.

asnumber takip

asnumber takip

 

bgp network agı

bgp network agı


Mikrotik yönlendiricimizin Temel IP adresini yapılandırın

[admin@Admin]/ip address >

add address=10.0.0.2/30 network=10.0.0.0 broadcast=10.0.0.3 interface=WAN1

add address=172.16.0.2/30 network=172.16.0.0 broadcast=172.16.0.3 interface=WAN2

AS number Ayarları
[admin@Admin]/routing bgp instance>
set default as=100

BGP Neighbor Ayarı

[admin@Admin]/routing bgp peer>add name=ISP1 remote-address=10.0.0.1 remote-as=200
[admin@Admin]/routing bgp peer>add name=ISP2 remote-address=172.16.0.1 remote-as=300


BGP peer Doğrulama

[admin@Admin] /routing bgp peer> print
Flags: X – disabled, E – established
 #   INSTANCE        REMOTE-ADDRESS                                 REMOTE-AS
 0 E default                     10.0.0.1                                                      200    
 1 E default                     172.16.0.1                                                  300


Network Advertisement Ayarlarımız

[admin@Admin]>
/routing bgp network
add network=192.168.10.0/24 synchronize=no


Gelen ve Giden Ayarları Filter Chain For ISP 1

[admin@Admin]>
/routing filter
add chain =ISP_1-out prefix=192.168.10.0/24 action=accept
add chain=ISP_1-out action=discard
[admin@Admin]>
/routing filter
add chain=ISP_1-in action=discard

Gelen ve Giden Ayarları Filter Chain For ISP 2
[admin@Admin]>
/routing filter
add chain =ISP_2-out prefix=192.168.10.0/24 action=accept set-bgp-prepend=5
[admin@Admin]>
/routing filter
add chain=ISP_2-in action=discard

[admin@Admin]>
/ip route
add gateway=10.0.0.1 check-gateway=ping
add gateway=172.16.0.1 check-gateway=ping distance=10

Click to comment

You must be logged in to post a comment Login

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

popüler yazılar

To Top
%d blogcu bunu beğendi: