Network

Cisco OSPF İle Dinamik Yönlendirme

OSFP-Topology

OSPF Çalışma mantığını anlayalım

 

Link State Protoklü olan OSPF Distance  Vektor Protocol de olduğu gibi bir update mantıgı değildir. Komşu Router aktif mi değil mi diye 10 Saniye aralıklar ile Hello paketleri gönderip Up olup olmadıklarını kontrol etmektedir.

 

Otonom sistemler de tüm Area’lar backbone area ( Omurga Alanı ) olan Area0 a bağlı olmak zorundadır.

Area’lar arasında bağlantıyı ABR ( Area Border Router / Alan Sınırı Yönlendiricisi ) Router sistemi sağlar. Aşşagı ya ekledigimiz görselde R2 ve R3 router’lar ABR router olarak vazife görmektedirler.

OSFP-Topology


 

OSPF Konfigürasyonu Yapılandırması

Area’lar router sayısı artıkça LSA Paketi sayısı aaynı oranda artaacagını bilmeniz gereklidir. Bu neden ile oluşan LSDB boyutu büyür ve Cpu ( İşlemci ) Kullanımı artacaktır. Area oluşturarak sadece o area da gerekecek olan router lara bildireceğiz. Bu sayede gereksiz olan network trafigini diger router lar görmemiş olacaktır. 1 Den fazla oluşturulan Area Sistemlerine Otonom Sistemi ( Automous System)

 

AREA0-ROUTER1 Konfigürasyon ayarı

Router>en

Router#conf t

Router(config)#hostname AREA0-ROUTER1

AREA0-ROUTER1[config)#interface gigabitEthernet 0/0

AREA0-ROUTER1[config-if)#ip address 10.10.10.1 255.255.255.0

AREA0-ROUTER1[config-if)#no shutdown

AREA0-ROUTER1[config-if)#ex


AREA0-ROUTER1[config)#interface serial 0/0/0

AREA0-ROUTER1(config-if)#87.87.87.2 255.255.255.0

AREA0-ROUTER1(config-if)#ip ospf priarity 1

AREA0-ROUTER1(config-if)#clock rate 128000

AREA0-ROUTER1(config-if)#no shutdown

AREA0-ROUTER1(config-if)#ex


AREA0-ROUTER1[config)#interface serial 0/0/1

AREA0-ROUTER1(config-if)#88.88.88.1 255.255.255.0

AREA0-ROUTER1(config-if)#ip ospf priarity 1

AREA0-ROUTER1(config-if)#clock rate 128000

AREA0-ROUTER1(config-if)#no shutdown

AREA0-ROUTER1(config-if)#ex

AREA0-ROUTER1(config)#do write

AREA0-ROUTER1(config)#end


AREA0-ROUTER1 Hostname olan Router a kendine bağlı olan komşu AREA bilgilerini tanımlayacağız.

AREA0-ROUTER1#conf t

AREA0-ROUTER1(config)#router ospf 1

AREA0-ROUTER1(config-router)#network 87.87.87.0 0.0.0.255 area 0

AREA0-ROUTER1(config-router)#network 88.88.88.0 0.0.0.255 area 0

AREA0-ROUTER1(config-router)#network 10.10.10.0 0.0.0.255 area 0

AREA0-ROUTER1(config-router)#do wr


AREA-1 Konfigürasyon ayarı

 

ABR-ROUTER1 Konfigürasyon ayarı

Router>en

Router#config t

Router(config)#hostname ABR-Router1

ABR-Router1(config)#interface serial 0/0/0

ABR-Router1(config-if)# ip address 87.87.87.1 255.255.255.0

ABR-Router1(config-if)#ip ospf priority 1

ABR-Router1(config-if)#no shutdown

ABR-Router1(config-if)#ex

ABR-Router1(config)#interface serial 0/3/0

ABR-Router1(config-if)#ip address 86.86.86.1 255.255.255.0

ABR-Router1(config-if)#ip ospf priority 1

ABR-Router1(config-if)#clock rrate 128000

ABR-Router1(config-if)#no shutdown

ABR-Router1(config-if)#ex

ABR-Router1(config)#do write

ABR-Router1(config)#end


ABR-Router1 Hostname adresine sahip olan Router a kendisi ne bağlı olan network bilgilerini girecegiz.

ABR-Router1#conf t

ABR-Router1(config)#router ospf 1

ABR-Router1(config-router)#network 87.87.87.0 0.0.0.255 area 1

ABR-Router1(config-router)#network 86.86.86.0 0.0.0.255 area 1

ABR-Router1(config-router)#do wr


AREA1-ROUTER1 OSPF YAPILANDIRMA

Router>en

Router#config t

Router(config)#hostname AREA1-ROUTER1

AREA1-ROUTER1(config)#interface gigabitethernet 0/0

AREA1-ROUTER1(config-if)# ip address 10.10.20.1 255.255.255.0

AREA1-ROUTER1(config-if)#ip ospf priority 1

AREA1-ROUTER1(config-if)#no shutdown

AREA1-ROUTER1(config-if)#ex

AREA1-ROUTER1(config)#interface serial 0/0/0

AREA1-ROUTER1(config-if)# ip address 86.86.86.2 255.255.255.0

AREA1-ROUTER1(config-if)#no shutdown

AREA1-ROUTER1(config-if)#ex

AREA1-ROUTER1#do wr


AREA1-ROUTER1 hostname adlı router ın kendisine bağlı olan networklerin tanımlamasını yapacağız.

ABR-Router1#conf t

ABR-Router1(config)#router ospf 1

ABR-Router1(config-router)#network 86.86.86.0 0.0.0.255 area 1

ABR-Router1(config-router)#network 10.10.20.0 0.0.0.255 area 1

ABR-Router1(config-router)#do wr


AREA-2 Konfigürasyon ayarı

 

ABR-ROUTER2 Konfigürasyon ayarı

Router>en

Router#config t

Router(config)#hostname ABR-Router2

ABR-Router2(config)#interface serial 0/0/0

ABR-Router2(config-if)# ip address 88.88.88.2 255.255.255.0

ABR-Router2(config-if)#ip ospf priority 1

ABR-Router2(config-if)#no shutdown

ABR-Router2(config-if)#ex

ABR-Router2(config)#interface serial 0/3/0

ABR-Router2(config-if)#ip address 89.89.89.2 255.255.255.0

ABR-Router2(config-if)#ip ospf priority 1

ABR-Router2(config-if)#clock rrate 128000

ABR-Router2(config-if)#no shutdown

ABR-Router2(config-if)#ex

ABR-Router2(config)#do write

ABR-Router2(config)#end


ABR-Router2 Hostname adresine sahip olan Router a kendisi ne bağlı olan network bilgilerini girecegiz.

ABR-Router1#conf t

ABR-Router1(config)#router ospf 1

ABR-Router1(config-router)#network 88.88.88.0 0.0.0.255 area 1

ABR-Router1(config-router)#network 89.89.89.0 0.0.0.255 area 1

ABR-Router1(config-router)#do wr


AREA2-ROUTER1 OSPF YAPILANDIRMA

Router>en

Router#config t

Router(config)#hostname AREA2-ROUTER1

AREA2-ROUTER1(config)#interface gigabitethernet 0/0

AREA2-ROUTER1(config-if)# ip address 10.10.30.1 255.255.255.0

AREA2-ROUTER1(config-if)#no shutdown

AREA2-ROUTER1(config-if)#ex

AREA2-ROUTER1(config)#interface serial 0/0/0

AREA2-ROUTER1(config-if)# ip address 89.89.89.2 255.255.255.0

AREA2-ROUTER1(config-if)#ip ospf priority 1

AREA2-ROUTER1(config-if)#clock rate 128000

AREA2-ROUTER1(config-if)#no shutdown

AREA2-ROUTER1(config-if)#ex

AREA2-ROUTER1#do wr


AREA2-Router1 Hostname adresine sahip olan Router a kendisi ne bağlı olan network bilgilerini girecegiz.

ABR-Router1#conf t

ABR-Router1(config)#router ospf 1

ABR-Router1(config-router)#network 89.89.89.0 0.0.0.255 area 1

ABR-Router1(config-router)#network 10.10.30.0 0.0.0.255 area 1

ABR-Router1(config-router)#do wr


OSPF Kurulum Test Yapıyoruz

 

Kodların Tam olarak Cihazlar içine yazılım dizilimi altta yer almaktadır.

area 0 için kodlar;
gövde router:
enable
configure terminal
interfaces serial 0/2/1
ip address 86.86.86.2 255.255.255.0
no shutdown
exit
interfaces g 0/0
no shutdown
exit
interfaces serial 0/2/0
ip address 87.87.87.1 255.255.255.0
no shutdown
exit
interfaces g 0/0.1
encapsulation dotQ 30
ip address 192.168.3.1 255.255.255.0
no shutdown
exit
ip dhcp pool 3
network 192.168.3.0 255.255.255.0
default-gateway 192.168.3.1
exit
do write
router ospf 1
network 86.86.86.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
network 87.87.87.0 0.0.0.255 area 0
exit
do write
———————————–
area 0
swicth:
enable
configure terminal
vlan 30
exit
interfaces f 0/1
swicthport mode trunk
exit
interfaces f 0/2
swicthport mode access
swicthport access vlan 30
exit
do write
—————————————
area 1 için kodlar:
Arb router :
enable
configure terminal
interfaces serial 0/2/1
ip address 89.89.89.2 255.255.255.0
no shutdown
exit
interfaces serial 0/2/0
ip address 86.86.86.1 255.255.255.0
no shutdown
exit
router ospf 1
network 86.86.86.0 0.0.0.255 area 0
network 89.89.89.0 0.0.0.255 area 1
exit
do write
——————————
area 1 router için:
enable
configure terminal
interfaces serial 0/2/0
ip address 89.89.89.1 255.255.255.0
no shutdown
exit
interfaces g 0/0
no shutdown
exit
interfaces g 0/0.1
encapsulation dotQ 20
ip address 192.168.2.1 255.255.255.0
no shutdown
exit
ip dhcp pool 2
network 192.168.2.0 255.255.255.0
default-gateway 192.168.2.1
exit
do write
router ospf 1
network 89.89.89.0 0.0.0.255 area 1
network 192.168.2.0 0.0.0.255 area 1
exit
do write
———————————
area 1 swicth için
enable
configure terminal
vlan 20
exit
interfaces f 0/1
swicthport mode trunk
exit
interfaces f 0/2
swicthport mode access
swicthport access vlan 20
exit
do write
—————————————–
area 2 kodlar için
arb router:
enable
configure terminal
interfaces serial 0/2/0
ip address 87.87.87.2 255.255.255.0
no shutdown
interfaces serial 0/2/1
ip address 88.88.88.2 255.255.255.0
no shutdown
exit
router ospf 1
network 87.87.87.0 0.0.0.255 area 0
network 88.88.88.0 0.0.0.255 area 2
exit
———————————-
area 2 router:
enable
configure terminal
interfaces serial 0/2/1
ip address 88.88.88.1 255.255.255.0
no shutdown
exit
interfaces g 0/0
no shutdown
exit
interfaces g 0/0.1
encapsulation dotQ 10
ip address 192.168.1.1 255.255.255.0
exit
ip dhcp pool 1
network 192.168.1.0 255.255.255.0
default-gateway 192.168.1.1
exit
router ospf 1
network 88.88.88.0 0.0.0.255 area 2
network 192.168.1.0 0.0.0.255 area 2
exit
do write
——————————
area 2 swicth:
enable
configure terminal
vlan 10
exit
interfaces f 0/1
swicthport mode trunk
exit
interfaces f 0/2
swicthport mode access
swicthport access vlan 10
exit
do write
————————————

Click to comment

You must be logged in to post a comment Login

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

popüler yazılar

To Top
%d blogcu bunu beğendi: